#1 2017-01-13 00:52:54

ryo
Member
Registered: 2017-01-13
Posts: 4

マイコンに書き込めない

マイコンを購入してHPに従ってスケッチを書き込みました。
正常に動きましたが、
スケッチを修正し、2度目の書き込みを行おうとした際、arduinoの
アプリがマイコンのシリアルポートを認識しません。
他の純正arduino uno などは問題なく認識しますし、
USBのコードを変えたりしましたが変わりません。
リセットボタンを押したままUSBコードを指すと
はじめは認識するのですが選択すると項目から消えてしまって
またシリアルポートを認識しなくなります。
何か問題あるのでしょうか。それとも書き込みは一度だけしか許されないのでしょうか?

OSはmac OSSierra10.12.2    arduinoは1.8.1です。ちなみにarduinoの一つ前のバージョンからダメでした。

Offline

#2 2017-01-16 06:50:30

Guvalif
Moderator
From: Osaka / Japan
Registered: 2015-08-31
Posts: 130
Website

Re: マイコンに書き込めない

書き込みは複数回可能です。

- 基板を接続するUSBポートを変更する
- Arduino IDEを起動しなおす
- PCを起動しなおす
等で認識されないか、確認していただくことは可能でしょうか??

また、上記の方法で認識しない場合でも、「ファイル >> 環境設定 >> 書き込みを検証する」にチェックをいれた状態で書き込みを行い、
画面下,黒い部分に「PORTS {} / {} => {}」と表示されたタイミングでリセットボタンを押下することで、通常であれば書き込みは可能です。

なお現状、Windows環境では同様な現象は確認されなかったため、もしその他のボードに関しても症状が発生する場合、
OS X版におけるバグではないかと考えられます。
詳しくは右記をチェックしてみると良いかもしれません。 https://github.com/arduino/Arduino/issues

Last edited by Guvalif (2017-01-16 06:52:07)

Offline

#3 2017-01-19 01:21:59

ryo
Member
Registered: 2017-01-13
Posts: 4

Re: マイコンに書き込めない

ボード自体をシリアルポートが認識していないので試す事ができませんでした。
ネットを調べているとMACはarduino互換機に対してFTDIシリアル変換の問題が
生じているようなのですがそれとは関係がないのでしょうか?
このボード自体はMACの場合はサポートされていないのでしょうか?
原因がわからずお手上げなので修理依頼したいと思います。

Offline

#4 2017-01-19 01:28:43

ryo
Member
Registered: 2017-01-13
Posts: 4

Re: マイコンに書き込めない

ボードのリセットボタンを押した後数秒間はLEDが明滅していてその間だけシリアルが認識しますが
数秒後LEDが消えると認識しなくなります。
通常はUSBつなげているときはLEDは明滅していますか、点灯していますか、消えていますか?

Offline

#5 2017-01-19 07:02:42

Guvalif
Moderator
From: Osaka / Japan
Registered: 2015-08-31
Posts: 130
Website

Re: マイコンに書き込めない

ボード自体をシリアルポートが認識しない状態でも、#2の方法は試すことが可能です。(具体的には以下の通りです。)

1. "ファイル >> 環境設定 >> 書き込みを検証する" にチェックをいれる。
2. USB micro B ケーブルで基板とPCを接続する。
3. "ツール >> ボード"を"Arduino/Genuino Micro" (名前にMicroと入るものであれば、それが正しいです。) と選択する。
4. マイコンボードに書き込みを行う。(ここまでで、ポートの選択は必要ありません。)
5. "PORTS {} / {} => {}" と画面下部に表示されだしたタイミングでリセットボタンを押下する。

一度お試しいただくことは可能でしょうか?

Offline

#6 2017-01-20 02:41:25

ryo
Member
Registered: 2017-01-13
Posts: 4

Re: マイコンに書き込めない

今日の朝そちらにオフィスにコントロールボードを送らせていただきました。
サーボモータの挙動もおかしいので(スイッチ入れると毎回ホームポジションが同じ方向に移動していく)
きちんと動いているか確認していただけませんか?
ちなみにwindowsPCでも認識しないようなので何かしらの問題は生じていると思います。
よろしくお願いします。

Offline

Board footer

Powered by FluxBB