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There will be some steps where force or strength is necessary. Please take the proper measures and
precautions to not hurt yourself or damage the parts and follow the instructions as described.
Please read the entire assembly instructions once before beginning the assembly.
Before assembling, check the content list to see if any parts are missing.
You will need a phillips screwdriver (+ head) for assembly.
Please use the provided pictures as a reference during assembly.
You will need to download some programs required for assembly to the M5Stack. Please refer to 7.
Writing the Firmware.
Please be aware that the colours and/or appearances of some parts in the reference photos provided
may be slightly different.
When assembling the servo motors, the initial rotational position of the gear on the motors is important.
The assembly instructions includes initial positioning for the motors. Please ensure all motors are
properly set.
The servo cable on the arm of PLEN5Stack can breaks when caught and wrapped. Before turning on the
power, make sure the arm cables are free and loose on the upper side.

1. Assembly Precautions
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1. Remove the micro:bit from your PLEN:bit.
2. Remove the two screws in the control board.
3. Slide the control board forward.
4. Remove the chest piece
5. Remove all the cables from the control board:

Servo motors, power cable, eye LED cable
6. Remove the control board
7. Remove the head piece

While pushing the bottom part of the head, lift the head from the top up and out.
8. Loosen the eye LED screws.
9. Remove the cable from the eyes control board

10. Remove the eyes control board
Leave the cable passed through the chest area

1. Write the firmware to PLEN5Stack
Please refer to 7. How to write the firmware

2. Connect the servo motor cables in order into the PLEN5Stack control board
Please refer to 3.1 Servo Motor Connectors
Please refer to 8.2 Control Board Terminal Name for the connection order.

3. Connect the power cable and eye LED cables to the control board.
4. Attach the PLEN5Stack eye control board inside the head part.

Please refer to 4.11 Attaching Head Part
5. Conenct the chest part

Please refer to 4.12 Attaching Chest Part
6. Replace the arm parts

The arm parts can be easily removed by inserting a thin flate object, such as a flat head
screwdriver, between the arm parts and the shoulder parts (on the opposite side of the servo horn).
Please refer to 4.8 Attaching the Arms

7. Motion check → refer to 5. Motion Check

Procedure for Conversion Kit

1. Remove parts from PLEN:bit

Please refer to the PLEN:bit assembly manual to see how to remove the follow parts in reverse order

2. Connecting the Conversion Kit Parts
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Contents List

No Name No Name No Name

1 M5Stack（not included） 11 Servo Bracket 21 Servo Horn × 6

2 Battery 12 Servo Fixer 22 PLEN5Stack Sticker ●

3 Control Board ● 13 Back Parts 23 QR Code ●

4 Servo Motors × 8 14 Switch Holder 24 Long sticker

5 Eye LED Board ● 15 Shoulder Parts x 2

6 Eye LED Spacers ● 16 Arm Parts × 2 ●

7 Eye LED Cables 17 Thigh Parts × 2

8 Head Part (Upper) 18 Leg Parts × 2

9 Head Part (Lower) 19 Black Screws × 4

10 Chest Part ● 20 Silver Screws × 4 ●

※The contents of the conversion kit are marked with ●

2. Contents List
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1. The servo motor connectors have a correct orientation. There are two black cables and one white cable,
where the white cable is the signal, the center is power, and the last is ground. Insert each cable such
that the white cable is on the inside.

Pay attention to connector orientation

3. Servo Motor Precautions

3.1 Servo Motor Connectors
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1. Body balance is important for bipedal robots. Since each servo motor is unique and will have its own
initial rotation angle, it will be necessary to adjust each individual servo motor. If this adjustment is not
done, your robot will not be able to walk properly, or will fall easily. Here we will explain how to complete
this adjustment。

2. The servo horn has a small offset between the inner serration and the front cross. When rotating the
cross of the servo horn over the gear of the servo motor, there should be a point where the cross is
approximately horizontal. Please attach the servo horn onto the servo motor gears at this horizontal
position.

3. There is a method of adjusting the servo motor initial position by program that is still in production. The
shoulder parts, for one, are integrated with the servo horn, and must be adjusted by this program.

Angle Adjustment

3.2 Servo Motor Angles
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1. Servo Motors ×8
2. Long Label sticker
3. Pen

Items Needed

4. Assembly

4.1 Preparation

Necessary Items
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Sticker placement

Procedure

Put the servo number stickers to each servo motor cable. Write the numbers 0-7 on eight stickers and fold
each over the cable of each servo motor.



plen5stack_manual_en.md 8/31/2020

11 / 60

For the Conversion Kit

4.2 Switch Board Assembly

For those with the Conversion Kit:

For those with the PLEN5Stack Conversion Kit, please use the original PLEN:bit switch board as before.

Please proceed to the next page for the regular assembly

PLEN5Stack uses a dedicated switch holder instead of the switch board.
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1. Back part
2. Switch holder
3. Battery
4. Control Board
5. M5Stack

Necessary Items

4.3 Circuit Board and Battery Wiring

Necessary Items
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Procedure

1. Connect the battery to the control board

2. Fit the switch holder into the back part
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-If you have not written the firmware, please see the [[7. Writing the firmware]] (#7.) page

3. Lightly insert the M5Stack onto the control board. Do not force the board

4. The following below is a complete set of the electrical equipment



plen5stack_manual_en.md 8/31/2020

15 / 60

1. Servo Motor ×4 (#0,#1,#4,#5)
2. Servo Bracket

Necessary Items

4.4 Servo Motor Assembly

Necessary Items
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Procedure

1. Orient the servo bracket such that the long back is horizontal and towards the back when inserting the
servo motors. The side of the bracket with this long bar in the middle is the "back" of the part and
concordantly the back of the robot. Insert servo motor #0 into the servo bracket as shown. This will be the
robot's left arm. Be careful not to have the cable of servo motor #0 pinched between the motor casing and
plastic parts when assembling. Have the servo motor cable come out the "front" side of the bracket.

2. Insert servo motor #4 following the same procedure as #0 on the opposite side of the bracket.
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3. Insert servo motor #1 below servo motor #0 with the gear part facing down. Again, be careful not to
have the cable of servo motor #1 pinched between the motor casing and plastic parts when assembling.

4. Insert servo motor #5 following the same procedure as #1 in the last available position in the bracket.
Ensure all servo motor cables are coming out the "front" face of the bracket.
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1. The previously assembled servo bracket with servo motors.
2. Complete Electrical set
3. Thigh plastic parts ×2
4. Servo horn ×2
5. Black screws ×2

Necessary items

4.5 Thigh Assembly

Necessary Items
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-If you have not written the firmware yet, please refer to 7. How to write the firmware.

Procedure

1. Ensure the switch board switch is in the off position. Connect servo motors #1 and #5 to the control
board pins as shown. When connecting the motors into the pins, ensure that the black (ground) cable is
towards the outside of the control board. Turn on the switch on the M5Stack.

2. The screen of M5Stack will be displayed and the servo motor will rotate and be initialized.
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3. Fix the servo horns on servo motors #1 and #5 as shown in the reference photo.

4. Attach the plastic thigh parts. Ensure the bump on the thigh parts is facing forward, the same direction
the servo cables are exiting the chest.
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5. Screw in the plastic thigh parts with screws.

6. This stage of the assembly is now complete.
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1. Chest assembly
2. Electrical parts
3. Servo motors ×2 (#3 and 7)
4. Plastic feet parts ×2
5. Servo horn ×2

Necessary Items

4.6 Leg Assembly

Necessary Items
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Procedure

1. Insert servo motors #3 and #7 to the thigh parts. Servo motor #3 is to be placed as the robot's left leg as
seen in the photo.

2. Connect servo motors #3 and #7 to the control board and power on the M5Stack.
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3. The servo motors will automatically rotate and be initialized.

4. Place a servo horn on each servo motor with the "+" pointing vertically and horizontally as shown in the
photo.
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5. Attach the plastic feet parts such that the wider area of the feet are on the outside.

6. This stage of the assembly is now complete.
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1. Chest assembly
2. Electrical parts
3. Plastic shoulder parts ×2
4. Black screw ×2

Necessary Items

4.7 Shoulder Assembly

Necessary Items
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Procedure

1. Connect servo motors #0 and #4 to the control board and power on the M5Stack.

2. The servo motors will automatically rotate and be initialized.
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3. Attach the shoulder parts such that they are as horizontal as possible and fix them with screws.

4. Repeat for the opposite side.
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5. This stage of assembly is now complete.
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1. Chest assembly
2. Electric parts
3. Plastic arm parts ×2
4. Servo motors ×2 (#2 and 6)
5. Servo horn ×2

Necessary Items

4.8 Arm Assembly

Necessary Items
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Procedure

1. Insert the servo motors into the plastic arm parts.

2. Connect servo motors #2 and #6 to the control board and power on the M5Stack.
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3. The servo motors will automatically rotate and be initialized.

4. Place a servo horn on each servo motor with the "+" pointing vertically and horizontally as shown in the
photo with the arms aligned vertically.
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5. Attach the arm parts into the shoulder parts lining up the servo horn "+" in the shoulder parts. Be careful
not to let the servo motor cable get caught.

6. This stage of the assembly is now complete.
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1. Chest assembly
2. Servo fixer

Necessary Items

4.9 Servo Fixer Attachment

Necessary Items
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※if it is difficult to attach, remove the servo motor cable from the control board, attach the servo fixer, and
then reconnect the cables.

Procedure

1. Servo Fixer attachment

2. Pass the cables from servo motors #3 and 7 in the legs up through the hole at the bottom of the servo
bracket.

3. Mount the servo fixer into the front of the servo bracket so that other cables are not pinched.
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1. Chest assembly
2. Electric parts

Necessary Items

4.10 Control Board Wiring

Necessary Items
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Procedure

1. Remove the battery from the control board.

2. Pass the battery cable through the back side of the servo bracket and reconnect it into the control
board.
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※Below, the complete electrical boards and parts are inside the body.

3. Place the battery in the back part and fix it to the body.
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6. This stage of the assembly is now complete.
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1. Body assembly
2. Head plastic parts (top and bottom)
3. Eye LED Board
4. Eye LED Cable
5. Eye LED Spacers

Necessary Items

4.11 Head Assembly

Necessary Items
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Procedure

1. Leaving the head parts separate, insert the bottom head part into the neck part of the body.

2. Connect the eye LED cable into the eye LED board and pass the cable through the bottom hole in the
head part and have it come out the front of the servo bracket.



plen5stack_manual_en.md 8/31/2020

42 / 60

3. Insert the LEDs with eye LED board into the eye slots and bottom half of the head.

4. Pass the eye LED cable for the center board through the hole in the head part.
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Then, turn the spacer cut-out outward.

5. Pass the eye LED spacers through the eye LED board (be careful; this may take force).
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7. Attach the top part of the head to the bottom, closing the eye LED board inside.

8. Connect the eye LED cable into the main control board in the chest.
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6. This stage of assembly is now complete.
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1. Body assembly
2. Plastic chest part
3. M5Stack
4. Silver screws ×4

Necessary Items

4.12 Chest Assembly

Necessary Items
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Procedure

1. Remove the M5Stack from the control board.

2. Pass the control board through the chest part at the front side.
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3. Attach the chest part to the body.

4. Screw in the chest part to the body with the screws.
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5. Re-insert the M5Stack on the front.

6. Power on the M5Stack and make sure all servo motors are in initial position. Some may rotate
automatically slightly back to this initial position.

7. Confirm that the limbs work by pressing the A and B buttons on the M5Stack. The eye LEDs should
blink with the C button.
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1. Press the B button to check if PLEN will walk.
2. That's it! We're done! Enjoy your PLEN5Stack!
3. But, if it doesn't walk...

Your PLEN5Stack might try to walk but will fail and fall over if the servo horn "+" angle was installed at an
incorrect angle.
It is possible to make minor adjustments using the program.

The PLEN5Stack library version 1.0.4 or later is required. Please refer to "7.5 Install library" and select
version [1.0.4] or later when installing

1. Open and follow the path: [File] → [Sketch example] → [PLEN5Stack] → [Servo Adjust]
2. Connect the M5Stack to a computer with the USB-c cable
3. Click the upload button [→].

1. Initial Screen

A button: Start adjustment
B button: Confirm motion
C button: The saved position's data is initialized

2. Start adjustment with A button -Adjust servo motors one by one

3. Use the A and B buttons to adjust the servo motor angle.

4. Switch to next servo motor with C button -The position of each is saved when you switch between them.

5. When you switch between all 8 servo motors, you will then return to the initial screen.

6. Press the power button on the left side of the front of the M5Stack. -The settings are updated.

7. Press B once again to check the movement.

5. Motion Check

5.1 PLEN's First Steps

5.2 Adjusting the Servo Motors

Follow these steps to make minor adjustments to the servo motor initial position.

Arduino IDE

Adjustment
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Press the button on the left side once, when viewing the M5Stack from the front.

Press the button on the left side twice quickly, when viewing the M5Stack from the front. 

Sticker

5.3 Power Supply

Turning the power on

Turning the power off

5.4 PLEN5Stack Sticker

Place the sticker where you see fit.



plen5stack_manual_en.md 8/31/2020

52 / 60

1. PLEN5Stack
2. USB-C Cable
3. PC or USB charger

1. Connect the USB-C cable to the M5Stack in the PLEN5Stack chest.
2. Connect the other end to a PC or USB charging outlet.

1. Turn on the switch on the back
2. Connect the USB-C cable to the M5Stack in the PLEN5Stack chest.
3. Connect the other end to a PC or USB charging outlet.

In this case, the LED on the upper right of the back will not light up.

1. Connect the micro USB cable to the back of PLEN5Stack. (Note the orientation of the connector)
2. Connect the other end to a PC or USB charging outlet.
3. The LED on the upper right of the back will light up.
4. Charging is finished when the LED turns off

Please do not connect any additional batteries to PLEN5 Stack in any way (such as a M5Stack battery
module). This will cause immediate failure.

※If you connect a USB cable to both the M5Stack and the back at the same time, it will charge from the
M5Stack side and ignore the charger in the back. For this reason, the charging speed will not change.
Therefore, we recommend to charge from the M5 Stack in the chest.

6. Battery Charging

6.1 Necessary Items

6.2 Connect the USB Cable

6.3 Using the Conversion Kit

Method 1 (Recommended)

Method 2 (Similar to PLEN:bit)

6.4 Cautions

For the Conversion Kit
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7. Writing the Firmware

7.1 Preliminary Arrangements

In order to write the PLEN5Stack firmware, you will need Arduino IDE ver.1.8.0 or later . Please download
and install beforehand.

7.2 How to Download the Arduino IDE

You can access the Arduino IDE download page and select your environment.

Click the part that says "JUST DOWNLOAD".

https://www.arduino.cc/en/Main/Software
https://www.arduino.cc/en/Main/Software
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1. "File" -> "Preferences"
2. Press the button to the right of the additional board manager URL
3. Enter the URL: https://dl.espressif.com/dl/package_esp32_index.json

7.3 Setting the Arduino IDE
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1. "Tools" -> "Board..." -> "Board Manager..."
2. Type "esp32" in the board manager
3. Install esp32

7.4 Install board
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1. "Sketch" -> "Include Library" -> "Manage Library..."

2. Enter "plen5stack" in the library manager
3. Install [ PLEN5Stack ]

4. Type "m5stack" in the library manager
5. Install [ M5Stack ]

6. Enter "neopixel" in the library manager
7. Install [ Adafruit NeoPixel ]

7.5 Install library

PLEN5Stack library

M5Stack library

Adafruit NeoPixel library
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1. "Tools" -> "Board..." -> "M5Stack-Core-ESP32"
2. "Tool" -> "Serial Port" -> Select (The port name will vary depending on the user environment.)

7.6 Select Board
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1. Open [File] → [Sketch example] → [PLEN5Stack] → [Firmware FullColor LED]
2. Connect M5Stack to your computer with the USB-C cable
3. Click the upload button [→].

7.7 Installation Procedure
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8. Reference

8.1 PLEN5Stack Servo Motor Number

8.2 Control board terminal
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PLENSupport: https://plen.jp/wp/contact/

Date of
Issue

Changes

2020/2/27 Pre-sale version

2020/6/23 Specification corrections (images、text)

2020/6/25 Switch board corrections

2020/6/30 Added links to table of contents, modified "Installation Procedure"

2020/7/2 Corrections of "Install library" and "Installation Procedure"

2020/7/3 Appearance changes, spelling error correction, conversion kit description added

2020/7/6 Charging methods included

2020/7/8 Changed the parts list and board images

2020/7/10
"Initialization adjustment" program added, image size adjustment, and appearance
modifications

2020/8/28 Translated version into English

2020/8/31 Change picture

9. Support

If you encounter any issues, please contact the us:

Changes History

https://plen.jp/wp/contact/

